#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)"\s*([#:].+?)\s*""
Local $sString = ""#sql/inline"" & @CRLF & _
"":username"" & @CRLF & _
""test"" & @CRLF & _
"" #sql/inline"" & @CRLF & _
"" :username"" & @CRLF & _
"" test"" & @CRLF & _
" " #sql/inline "" & @CRLF & _
" " :username "" & @CRLF & _
" " test ""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)