$re = '/"\s*([#:].+?)\s*"/m';
$str = '"#sql/inline"
":username"
"test"
" #sql/inline"
" :username"
" test"
" #sql/inline "
" :username "
" test "';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;