re = /"\s*([#:].+?)\s*"/m
str = '"#sql/inline"
":username"
"test"
" #sql/inline"
" :username"
" test"
" #sql/inline "
" :username "
" test "'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result