using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[monitor:///var/log/(messages|secure|cron|spooler|audit\.log)\](?:(?:\R.*){2})index=).*";
string substitution = @"$1$2";
string input = @"[monitor:///var/log/messages]
sourcetype=linux
index=power
[monitor:///var/log/secure]
sourcetype=linux
index=power";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}