use strict;
my $str = '[monitor:///var/log/messages]
sourcetype=linux
index=power
[monitor:///var/log/secure]
sourcetype=linux
index=power';
my $regex = qr`(\[monitor:///var/log/(messages|secure|cron|spooler|audit\.log)\](?:(?:\R.*){2})index=).*`mp;
my $subst = '$1$2';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";