import re
regex = re.compile(r"(\[monitor:///var/log/(messages|secure|cron|spooler|audit\.log)\](?:(?:\R.*){2})index=).*", flags=re.MULTILINE)
test_str = ("[monitor:///var/log/messages]\n"
"sourcetype=linux\n"
"index=power\n\n"
"[monitor:///var/log/secure]\n"
"sourcetype=linux\n"
"index=power")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)