re = /(\[monitor:\/\/\/var\/log\/(messages|secure|cron|spooler|audit\.log)\](?:(?:\R.*){2})index=).*/m
str = '[monitor:///var/log/messages]
sourcetype=linux
index=power
[monitor:///var/log/secure]
sourcetype=linux
index=power'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result