package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\[([^\]]+)\])`)
var str = `[fdsfs,fds,fds][gdsfgfds,gdsgsdg,sdgsd]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}