re = /(?:\[([^\]]+)\])/m
str = '[fdsfs,fds,fds][gdsfgfds,gdsgsdg,sdgsd]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result