import re
regex = re.compile(r"(?:\[([^\]]+)\])", flags=re.MULTILINE)
test_str = "[fdsfs,fds,fds][gdsfgfds,gdsgsdg,sdgsd]"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)