#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<\?fileVersion 4\.0\.0\?>)\s"
Local $sString = "<?xml version="1.0" encoding="UTF-8" standalone="no"?>" & @CRLF & _
"<?fileVersion 4.0.0?>" & @CRLF & _
"<cproject storage_type_id="org.eclipse.cdt.core.XmlProjectDescriptionStorage">" & @CRLF & _
" <storageModule moduleId="org.eclipse.cdt.core.settings">" & @CRLF & _
" <cconfiguration id="com.st.stm32cube.ide.mcu.gnu.managedbuild.config.exe.debug.1508274248">" & @CRLF & _
" <storageModule buildSystemId="org.eclipse.cdt.managedbuilder.core.configurationDataProvider" id="com.st.stm32cube.ide.mcu.gnu.managedbuild.config.exe.debug.1508274248" moduleId="org.eclipse.cdt.core.settings" name="Debug">"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)