# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<\?fileVersion 4\.0\.0\?>)\s"
test_str = ("<?xml version=\"1.0\" encoding=\"UTF-8\" standalone=\"no\"?>\n"
"<?fileVersion 4.0.0?>\n"
"<cproject storage_type_id=\"org.eclipse.cdt.core.XmlProjectDescriptionStorage\">\n"
" <storageModule moduleId=\"org.eclipse.cdt.core.settings\">\n"
" <cconfiguration id=\"com.st.stm32cube.ide.mcu.gnu.managedbuild.config.exe.debug.1508274248\">\n"
" <storageModule buildSystemId=\"org.eclipse.cdt.managedbuilder.core.configurationDataProvider\" id=\"com.st.stm32cube.ide.mcu.gnu.managedbuild.config.exe.debug.1508274248\" moduleId=\"org.eclipse.cdt.core.settings\" name=\"Debug\">")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.