import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<\\?fileVersion 4\\.0\\.0\\?>)\\s";
final String string = "<?xml version=\"1.0\" encoding=\"UTF-8\" standalone=\"no\"?>\n"
+ "<?fileVersion 4.0.0?>\n"
+ "<cproject storage_type_id=\"org.eclipse.cdt.core.XmlProjectDescriptionStorage\">\n"
+ " <storageModule moduleId=\"org.eclipse.cdt.core.settings\">\n"
+ " <cconfiguration id=\"com.st.stm32cube.ide.mcu.gnu.managedbuild.config.exe.debug.1508274248\">\n"
+ " <storageModule buildSystemId=\"org.eclipse.cdt.managedbuilder.core.configurationDataProvider\" id=\"com.st.stm32cube.ide.mcu.gnu.managedbuild.config.exe.debug.1508274248\" moduleId=\"org.eclipse.cdt.core.settings\" name=\"Debug\">";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}