using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\?fileVersion 4\.0\.0\?>)\s";
string substitution = @"$1";
string input = @"<?xml version=""1.0"" encoding=""UTF-8"" standalone=""no""?>
<?fileVersion 4.0.0?>
<cproject storage_type_id=""org.eclipse.cdt.core.XmlProjectDescriptionStorage"">
<storageModule moduleId=""org.eclipse.cdt.core.settings"">
<cconfiguration id=""com.st.stm32cube.ide.mcu.gnu.managedbuild.config.exe.debug.1508274248"">
<storageModule buildSystemId=""org.eclipse.cdt.managedbuilder.core.configurationDataProvider"" id=""com.st.stm32cube.ide.mcu.gnu.managedbuild.config.exe.debug.1508274248"" moduleId=""org.eclipse.cdt.core.settings"" name=""Debug"">";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}