#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*([^#][\w\d_-]+?)\[([\w\d_-]+?)]\s*=\s*(\d+[\.,]\d+)\s*$"
Local $sString = "; This is a sample configuration file" & @CRLF & _
"; Comments start with ';', as in php.ini" & @CRLF & _
"" & @CRLF & _
"[first_section]" & @CRLF & _
"one = 1" & @CRLF & _
"one = 3" & @CRLF & _
"one-two = 4" & @CRLF & _
"one_three = 3" & @CRLF & _
"five = 5.2" & @CRLF & _
"animal = BIRD" & @CRLF & _
"" & @CRLF & _
"[first_section]" & @CRLF & _
"second_section[one] = "1 associated"" & @CRLF & _
"second_section[two] = "2 associated"" & @CRLF & _
"second_section[] = "1 unassociated"" & @CRLF & _
"second_section[] = "2 unassociated"" & @CRLF & _
"second_section[] = 1" & @CRLF & _
"second_section[] = 1,3" & @CRLF & _
"second_section[] = 2,2" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[second_section]" & @CRLF & _
"path = "/usr/local/bin"" & @CRLF & _
"URL = "http://www.example.com/~username"" & @CRLF & _
"second_section[one] = "1 associated"" & @CRLF & _
"second_section[two] = "2 associated"" & @CRLF & _
"second_section[three] = 3" & @CRLF & _
"second_section[four] = 4.4" & @CRLF & _
"second_section[] = "1 unassociated"" & @CRLF & _
"second_section[] = "2 unassociated"" & @CRLF & _
"second_section[] = 1" & @CRLF & _
"second_section[] = 2.2" & @CRLF & _
"" & @CRLF & _
"[third_section]" & @CRLF & _
"phpversion[] = "5.0"" & @CRLF & _
"phpversion[] = "5.1"" & @CRLF & _
"phpversion[] = "5.2"" & @CRLF & _
"phpversion[] = "5.3""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")