using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*([^#][\w\d_-]+?)\[([\w\d_-]+?)]\s*=\s*(\d+[\.,]\d+)\s*$";
string input = @"; This is a sample configuration file
; Comments start with ';', as in php.ini
[first_section]
one = 1
one = 3
one-two = 4
one_three = 3
five = 5.2
animal = BIRD
[first_section]
second_section[one] = ""1 associated""
second_section[two] = ""2 associated""
second_section[] = ""1 unassociated""
second_section[] = ""2 unassociated""
second_section[] = 1
second_section[] = 1,3
second_section[] = 2,2
[second_section]
path = ""/usr/local/bin""
URL = ""http://www.example.com/~username""
second_section[one] = ""1 associated""
second_section[two] = ""2 associated""
second_section[three] = 3
second_section[four] = 4.4
second_section[] = ""1 unassociated""
second_section[] = ""2 unassociated""
second_section[] = 1
second_section[] = 2.2
[third_section]
phpversion[] = ""5.0""
phpversion[] = ""5.1""
phpversion[] = ""5.2""
phpversion[] = ""5.3""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}