import re
regex = re.compile(r"^\s*([^#][\w\d_-]+?)\[([\w\d_-]+?)]\s*=\s*(\d+[\.,]\d+)\s*$", flags=re.MULTILINE)
test_str = ("; This is a sample configuration file\n"
"; Comments start with ';', as in php.ini\n\n"
"[first_section]\n"
"one = 1\n"
"one = 3\n"
"one-two = 4\n"
"one_three = 3\n"
"five = 5.2\n"
"animal = BIRD\n\n"
"[first_section]\n"
"second_section[one] = \"1 associated\"\n"
"second_section[two] = \"2 associated\"\n"
"second_section[] = \"1 unassociated\"\n"
"second_section[] = \"2 unassociated\"\n"
"second_section[] = 1\n"
"second_section[] = 1,3\n"
"second_section[] = 2,2\n\n\n"
"[second_section]\n"
"path = \"/usr/local/bin\"\n"
"URL = \"http://www.example.com/~username\"\n"
"second_section[one] = \"1 associated\"\n"
"second_section[two] = \"2 associated\"\n"
"second_section[three] = 3\n"
"second_section[four] = 4.4\n"
"second_section[] = \"1 unassociated\"\n"
"second_section[] = \"2 unassociated\"\n"
"second_section[] = 1\n"
"second_section[] = 2.2\n\n"
"[third_section]\n"
"phpversion[] = \"5.0\"\n"
"phpversion[] = \"5.1\"\n"
"phpversion[] = \"5.2\"\n"
"phpversion[] = \"5.3\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")