# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bUsername\s*[:;]\s*\K\S+/REPLACEMENT/gmi;t' <<< "Username:dasdsad
username ;dasdsad
username : dasdsad
username; dasdsad"