import re
regex = re.compile(r"\bUsername\s*[:;]\s*\K\S+", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Username:dasdsad\n"
"username ;dasdsad\n"
"username : dasdsad\n"
"username; dasdsad")
subst = "REPLACEMENT"
result = regex.sub(subst, test_str)
if result:
print(result)