re = /\bUsername\s*[:;]\s*\K\S+/mi
str = 'Username:dasdsad
username ;dasdsad
username : dasdsad
username; dasdsad'
subst = 'REPLACEMENT'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result