package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(?m)<!--{if(\s+\(?(\$[^\s!=><}]+)[^}]+)}-->`)
    var str = `<!--{if $projectdisplaymode != 'Widget'}-->
<!--{if (isset($projectdisplaymode ) && $projectdisplaymode != 'Widget' )}-->
<!--{if $runnow == 'true'}-->
<!--{if (isset($runnow ) && $runnow == 'true' )}-->
<!--{if $showdelete == 'Yes'}-->
<!--{if $average_rating_colorclass == 'progress0'}-->
<!--{if ($percentage!="")}-->
--Find: <!--{if(\s+\(?(\$[^\s!=><}]+)[^}]+)}-->
--Replace: <!--{if (isset($2) && $1)}-->`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}