use strict;
my $str = '<!--{if $projectdisplaymode != \'Widget\'}-->
<!--{if (isset($projectdisplaymode ) && $projectdisplaymode != \'Widget\' )}-->
<!--{if $runnow == \'true\'}-->
<!--{if (isset($runnow ) && $runnow == \'true\' )}-->
<!--{if $showdelete == \'Yes\'}-->
<!--{if $average_rating_colorclass == \'progress0\'}-->
<!--{if ($percentage!="")}-->
--Find: <!--{if(\\s+\\(?(\\$[^\\s!=><}]+)[^}]+)}-->
--Replace: <!--{if (isset($2) && $1)}-->';
my $regex = qr/<!--{if(\s+\(?(\$[^\s!=><}]+)[^}]+)}-->/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}