import re
regex = re.compile(r"<!--{if(\s+\(?(\$[^\s!=><}]+)[^}]+)}-->", flags=re.MULTILINE)
test_str = ("<!--{if $projectdisplaymode != 'Widget'}-->\n"
"<!--{if (isset($projectdisplaymode ) && $projectdisplaymode != 'Widget' )}-->\n"
"<!--{if $runnow == 'true'}-->\n"
"<!--{if (isset($runnow ) && $runnow == 'true' )}-->\n"
"<!--{if $showdelete == 'Yes'}-->\n"
"<!--{if $average_rating_colorclass == 'progress0'}-->\n"
"<!--{if ($percentage!=\"\")}-->\n\n"
"--Find: <!--{if(\\s+\\(?(\\$[^\\s!=><}]+)[^}]+)}-->\n"
"--Replace: <!--{if (isset($2) && $1)}-->")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")