package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`http(?:s)?\:\/\/www\.\w+\.[\w]{2,}\/(?:(\w+)\/)+(?:\?\w+\=\w+)?`)
var str = `http://www.website.com/abcd/efg/xyz/the_string_i_want/?Cr=47
http://www.website.london/abcd/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}