re = /http(?:s)?\:\/\/www\.\w+\.[\w]{2,}\/(?:(\w+)\/)+(?:\?\w+\=\w+)?/
str = 'http://www.website.com/abcd/efg/xyz/the_string_i_want/?Cr=47
http://www.website.london/abcd/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end