$re = '/http(?:s)?\:\/\/www\.\w+\.[\w]{2,}\/(?:(\w+)\/)+(?:\?\w+\=\w+)?/';
$str = 'http://www.website.com/abcd/efg/xyz/the_string_i_want/?Cr=47
http://www.website.london/abcd/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);