import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http(?:s)?\\:\\/\\/www\\.\\w+\\.[\\w]{2,}\\/(?:(\\w+)\\/)+(?:\\?\\w+\\=\\w+)?";
final String string = "http://www.website.com/abcd/efg/xyz/the_string_i_want/?Cr=47\n\n"
+ "http://www.website.london/abcd/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}