#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?-s:(.*html$)|.*\R?)"
Local $sString = "https://gtorrent.club/uploads/posts/2023-01/1673515833_d89a354bc5c492c82993d819aa4a8d16.jpg" & @CRLF & _
"https://gtorrent.club/muzyka/rock/" & @CRLF & _
"https://gtorrent.club/muzyka/rock/209509-the-aaron-clift-experiment-diskografiya.html" & @CRLF & _
"https://gtorrent.club/uploads/posts/2023-01/1673515755_d1e7f6df21e006836992acae70aeadce.jpg" & @CRLF & _
"https://gtorrent.club/muzyka/rock/" & @CRLF & _
"https://gtorrent.club/muzyka/rock/209508-alisa-diskografiya.html" & @CRLF & _
"https://gtorrent.club/uploads/posts/2023-01/1673515771_0b407d9345814efbf8d1a214015b208e.jpg" & @CRLF & _
"https://gtorrent.club/muzyka/electronic/" & @CRLF & _
"https://gtorrent.club/muzyka/electronic/209507-ibangbang-watergun-colors.html"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)