use strict;
my $str = 'https://gtorrent.club/uploads/posts/2023-01/1673515833_d89a354bc5c492c82993d819aa4a8d16.jpg
https://gtorrent.club/muzyka/rock/
https://gtorrent.club/muzyka/rock/209509-the-aaron-clift-experiment-diskografiya.html
https://gtorrent.club/uploads/posts/2023-01/1673515755_d1e7f6df21e006836992acae70aeadce.jpg
https://gtorrent.club/muzyka/rock/
https://gtorrent.club/muzyka/rock/209508-alisa-diskografiya.html
https://gtorrent.club/uploads/posts/2023-01/1673515771_0b407d9345814efbf8d1a214015b208e.jpg
https://gtorrent.club/muzyka/electronic/
https://gtorrent.club/muzyka/electronic/209507-ibangbang-watergun-colors.html';
my $regex = qr/^(?-s:(.*html$)|.*\R?)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";