# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?-s:(.*html$)|.*\R?)"
test_str = ("https://gtorrent.club/uploads/posts/2023-01/1673515833_d89a354bc5c492c82993d819aa4a8d16.jpg\n"
"https://gtorrent.club/muzyka/rock/\n"
"https://gtorrent.club/muzyka/rock/209509-the-aaron-clift-experiment-diskografiya.html\n"
"https://gtorrent.club/uploads/posts/2023-01/1673515755_d1e7f6df21e006836992acae70aeadce.jpg\n"
"https://gtorrent.club/muzyka/rock/\n"
"https://gtorrent.club/muzyka/rock/209508-alisa-diskografiya.html\n"
"https://gtorrent.club/uploads/posts/2023-01/1673515771_0b407d9345814efbf8d1a214015b208e.jpg\n"
"https://gtorrent.club/muzyka/electronic/\n"
"https://gtorrent.club/muzyka/electronic/209507-ibangbang-watergun-colors.html")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.