import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?-s:(.*html$)|.*\\R?)";
final String string = "https://gtorrent.club/uploads/posts/2023-01/1673515833_d89a354bc5c492c82993d819aa4a8d16.jpg\n"
+ "https://gtorrent.club/muzyka/rock/\n"
+ "https://gtorrent.club/muzyka/rock/209509-the-aaron-clift-experiment-diskografiya.html\n"
+ "https://gtorrent.club/uploads/posts/2023-01/1673515755_d1e7f6df21e006836992acae70aeadce.jpg\n"
+ "https://gtorrent.club/muzyka/rock/\n"
+ "https://gtorrent.club/muzyka/rock/209508-alisa-diskografiya.html\n"
+ "https://gtorrent.club/uploads/posts/2023-01/1673515771_0b407d9345814efbf8d1a214015b208e.jpg\n"
+ "https://gtorrent.club/muzyka/electronic/\n"
+ "https://gtorrent.club/muzyka/electronic/209507-ibangbang-watergun-colors.html";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}