const regex = /([\d\-]+)\s+([^\s]+)\s+(.*)\s+\(([\d:]+)\)\r?\n(.*)\r?\n(.*)\r?\n(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\d\\-]+)\\s+([^\\s]+)\\s+(.*)\\s+\\(([\\d:]+)\\)\\r?\\n(.*)\\r?\\n(.*)\\r?\\n(.*)', 'gm')
const str = `0001-01-01 AB001 ..... . .... .. ..... (01:01)
AAAAAAA
BBBBBB
CCCCC
0002-02-02 AB002 ..... . .... .. ..... (02:02)
AAAAAAA
BBBBBB
CCCCC`;
const subst = `$2 $3\n$5 $2\n$6 $1\n$7 $4 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);