// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([\d\-]+)\s+([^\s]+)\s+(.*)\s+\(([\d:]+)\)\r?\n(.*)\r?\n(.*)\r?\n(.*)").unwrap();
let string = "0001-01-01 AB001 ..... . .... .. ..... (01:01)
AAAAAAA
BBBBBB
CCCCC
0002-02-02 AB002 ..... . .... .. ..... (02:02)
AAAAAAA
BBBBBB
CCCCC";
let substitution = "$2 $3\\n$5 $2\\n$6 $1\\n$7 $4 ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}