$re = '/([\d\-]+)\s+([^\s]+)\s+(.*)\s+\(([\d:]+)\)\r?\n(.*)\r?\n(.*)\r?\n(.*)/m';
$str = '0001-01-01 AB001 ..... . .... .. ..... (01:01)
AAAAAAA
BBBBBB
CCCCC
0002-02-02 AB002 ..... . .... .. ..... (02:02)
AAAAAAA
BBBBBB
CCCCC';
$subst = "$2 $3\n$5 $2\n$6 $1\n$7 $4 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;