import Foundation
let pattern = #"([\d\-]+)\s+([^\s]+)\s+(.*)\s+\(([\d:]+)\)\r?\n(.*)\r?\n(.*)\r?\n(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0001-01-01 AB001 ..... . .... .. ..... (01:01)
AAAAAAA
BBBBBB
CCCCC
0002-02-02 AB002 ..... . .... .. ..... (02:02)
AAAAAAA
BBBBBB
CCCCC
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2 $3\n$5 $2\n$6 $1\n$7 $4 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)