#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<street>[^,]+), (?<city>[^,]+), (?<state>[^,]+), (?<zip>[^,]+)"
Local $sString = "123 Main Street, New York, NY, 10110"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")