const regex = /(?<street>[^,]+), (?<city>[^,]+), (?<state>[^,]+), (?<zip>[^,]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<street>[^,]+), (?<city>[^,]+), (?<state>[^,]+), (?<zip>[^,]+)', '')
const str = `123 Main Street, New York, NY, 10110`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}