re = /(?<street>[^,]+), (?<city>[^,]+), (?<state>[^,]+), (?<zip>[^,]+)/
str = '123 Main Street, New York, NY, 10110'
# Print the match result
str.match(re) do |match|
puts match.to_s
end