#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0]*([1][1][0|2|5])|([1][1][6]\d{3})|([1][1][8][1-9]{2})"
Local $sString = "110" & @CRLF & _
"112" & @CRLF & _
"115" & @CRLF & _
"19222" & @CRLF & _
"116117" & @CRLF & _
"116116" & @CRLF & _
"11800" & @CRLF & _
"11811" & @CRLF & _
"11823" & @CRLF & _
"118222" & @CRLF & _
"11899" & @CRLF & _
"" & @CRLF & _
"1234" & @CRLF & _
"9987" & @CRLF & _
"1120" & @CRLF & _
"112554443"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")