import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0]*([1][1][0|2|5])|([1][1][6]\\d{3})|([1][1][8][1-9]{2})";
final String string = "110\n"
+ "112\n"
+ "115\n"
+ "19222\n"
+ "116117\n"
+ "116116\n"
+ "11800\n"
+ "11811\n"
+ "11823\n"
+ "118222\n"
+ "11899\n\n"
+ "1234\n"
+ "9987\n"
+ "1120\n"
+ "112554443";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}