const regex = /^[0]*([1][1][0|2|5])|([1][1][6]\d{3})|([1][1][8][1-9]{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0]*([1][1][0|2|5])|([1][1][6]\\d{3})|([1][1][8][1-9]{2})', 'gm')
const str = `110
112
115
19222
116117
116116
11800
11811
11823
118222
11899
1234
9987
1120
112554443`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}