# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[0]*([1][1][0|2|5])|([1][1][6]\d{3})|([1][1][8][1-9]{2})"
test_str = ("110\n"
"112\n"
"115\n"
"19222\n"
"116117\n"
"116116\n"
"11800\n"
"11811\n"
"11823\n"
"118222\n"
"11899\n\n"
"1234\n"
"9987\n"
"1120\n"
"112554443")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.