#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\/(?:[a-z0-9]+(?:[A-Z][a-z0-9]+)*|{[a-z0-9]+(?:[A-Z][a-z0-9]+)*}))+$"
Local $sString = "/acbAbf023/{acfAbc12}/asp/avbTfg/abd01" & @CRLF & _
"/abc" & @CRLF & _
"/abc/def" & @CRLF & _
"/abCd" & @CRLF & _
"/{abCd}" & @CRLF & _
"/{abCd}/efgHij" & @CRLF & _
"/{abc}/{abc}" & @CRLF & _
"" & @CRLF & _
"/A" & @CRLF & _
"/abC" & @CRLF & _
"/abCdE" & @CRLF & _
"/abcDeFGh" & @CRLF & _
"/{abc}/{abC}" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")