$re = '/^(?:\/(?:[a-z0-9]+(?:[A-Z][a-z0-9]+)*|{[a-z0-9]+(?:[A-Z][a-z0-9]+)*}))+$/m';
$str = '/acbAbf023/{acfAbc12}/asp/avbTfg/abd01
/abc
/abc/def
/abCd
/{abCd}
/{abCd}/efgHij
/{abc}/{abc}
/A
/abC
/abCdE
/abcDeFGh
/{abc}/{abC}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);