import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\/(?:[a-z0-9]+(?:[A-Z][a-z0-9]+)*|\\{[a-z0-9]+(?:[A-Z][a-z0-9]+)*\\}))+$";
final String string = "/acbAbf023/{acfAbc12}/asp/avbTfg/abd01\n"
+ "/abc\n"
+ "/abc/def\n"
+ "/abCd\n"
+ "/{abCd}\n"
+ "/{abCd}/efgHij\n"
+ "/{abc}/{abc}\n\n"
+ "/A\n"
+ "/abC\n"
+ "/abCdE\n"
+ "/abcDeFGh\n"
+ "/{abc}/{abC}\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}