package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\/(?:[a-z0-9]+(?:[A-Z][a-z0-9]+)*|{[a-z0-9]+(?:[A-Z][a-z0-9]+)*}))+$`)
var str = `/acbAbf023/{acfAbc12}/asp/avbTfg/abd01
/abc
/abc/def
/abCd
/{abCd}
/{abCd}/efgHij
/{abc}/{abc}
/A
/abC
/abCdE
/abcDeFGh
/{abc}/{abC}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}