using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[$](\{)?\w+(?(1)(?:[\/:].*})?)";
string input = @"$TM_FILENAME
${TM_FILENAME/[\.]/_/}
${1:OPT1|OPT2}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}