re = /[$](\{)?\w+(?(1)(?:[\/:].*})?)/m
str = '$TM_FILENAME
${TM_FILENAME/[\\.]/_/}
${1:OPT1|OPT2}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end