package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[$](\{)?\w+(?(1)(?:[\/:].*})?)`)
var str = `$TM_FILENAME
${TM_FILENAME/[\.]/_/}
${1:OPT1|OPT2}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}