import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+) +(@\\S+@)? *(\\S+) +(.*)";
final String string = "0 HEAD\n"
+ "1 CHAR UTF-8\n"
+ "1 SOUR Ancestry.com Family Trees\n"
+ "2 VERS (2010.3)\n"
+ "2 NAME Ancestry.com Family Trees\n"
+ "2 CORP Ancestry.com\n"
+ "1 GEDC\n"
+ "2 VERS 5.5\n"
+ "2 FORM LINEAGE-LINKED\n"
+ "0 @P6@ INDI \n"
+ "1 BIRT ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}